2026年7月
リリース一覧
Section titled “リリース一覧”| バージョン | リリース日 |
|---|---|
| v5.11.0 | 2026-07-09 |
| v5.11.1 | 2026-07-13 |
| v5.11.2 | 2026-07-15 |
| v5.11.4 | 2026-07-20 |
| v5.11.5 | 2026-07-21 |
| v5.11.6 | 2026-07-22 |
| v5.11.7 | 2026-07-22 |
| v5.11.8 | 2026-07-22 |
| v5.11.9 | 2026-07-22 |
-
新しいランチャー。 サインインすると、ランチャーが開くようになりました。最近のプロジェクト、ダッシュボードとPanelアプリ、ピン留めしたもの、最後の実行が失敗したワークフローをタイルにまとめた1ページで、3つのレーンに配置され、そこから直接操作できます。タイルを開く、ワークフローを実行する、失敗した実行に移動する、あるいは非表示にすることができます。ランチャー、または普段使っている一覧やドキュメントブラウザーから、あらゆるものをピン留めできます。対象は、プロジェクト、ワークフロー、テーブル、ディメンション、データエディター、ダッシュボード、Panelアプリ、およびファイルやフォルダー単位のドキュメントです。プロジェクトのタイルにはプロジェクトの概要(ワークフローの実行、ワークフロー、テーブル、レコード)が表示され、プロジェクトの「ホーム」タブの ランチャータイル画像 で、プロジェクトごとに設定できる淡い背景画像が付きます。タイル表示と密度の高いリスト表示を切り替えたり、表示したくない種類を非表示にしたりでき、Ctrl/Cmd-K を押すと、入力に合わせてプロジェクト、ワークフロー、テーブル、ダッシュボード、Panelアプリを検索できます。ランチャーを参照してください。
-
コレクションや仕様をRESTリクエストステップに貼り付け。 Postman、OpenAPI/Swagger、HARの各ソースに、ファイルピッカーの横に 貼り付け… ボタンが追加されました。先にドキュメントに保存しなくても、内容を直接指定できます。RESTリクエストステップを参照してください。
-
REST接続にAPI定義を関連付け。 汎用RESTとMuleSoftの接続に、独自のOpenAPI 3.xまたはSwagger 2.0の定義(公開アドレス、またはドキュメントに保存した仕様ファイル)を持たせられるようになりました。接続の API定義 で一度設定すれば、その接続を使うRESTリクエストステップで エンドポイントソース を 接続のAPI定義から に設定でき、メソッド、パラメーター、本文が入力済みの状態でAPIのエンドポイントを一覧表示できます。ステップごとに定義を記述し直す必要はありません。汎用REST接続とRESTリクエストステップを参照してください。
-
MuleSoftを接続タイプとして利用可能に。 新規接続メニューからMuleSoft Anypointゲートウェイを追加し、他のREST接続と同じように設定できます。ご自身のゲートウェイアドレスと、そのゲートウェイが求める認証方式を指定します。MuleSoft RESTコネクターを参照してください。
-
PlaidCloud Git接続。 ワークスペース専用のマネージドGitサーバーに、簡素化されたフォームで接続できます。入力するのは、アカウント名、メモ、リポジトリパス、デフォルトブランチ、任意の開始パスだけです。Gitサーバーとそのサーバーへのアクセスは通常のPlaidCloudサインインから得られるため、サーバーURL、ユーザー名、トークン、SSHキーを入力する必要はありません。サーバーPanelアプリのビルドをPlaidCloud Git接続に向ければ、外部のGitHubアカウントやアクセストークンなしで、ワークスペース内だけでビルドを自動化できます。外部のGitプロバイダー(GitHub、GitLab、Bitbucket、Forgejo、Gitea)では、従来どおりの完全な接続フォームが使われます。PlaidCloud Git接続を参照してください。
-
Currency — 金額のために作られた列データ型。 すべての列データ型リスト(ステップの出力列マッピング、データマッパーのグリッド、テーブルの列のプロパティ、MCP/AIツール)に 通貨 が追加されました。これは精度18桁、小数点以下4桁(約±100兆、1/10,000まで正確)の厳密な固定小数点型です。金額をNumericの半分のメモリ幅で保持するため、金額を多く扱うダッシュボードやワークフローステップは、スキャンするデータが約半分になり、より高速に動作します。Numericは引き続き高精度のデフォルト(38桁、小数点以下10桁)です。Currencyは常に明示的に選択するもので、インポート、型の検出、SQLの結果、派生列は引き続きNumericがデフォルトです。一度列に設定すると、読み取り、後続のステップ、テーブルの再構築を通じて保持されます。Currencyの集計結果はNumericで返されます。このオプションは、プラットフォームの更新がお使いのワークスペースで有効になると表示されます。Currencyデータ型を参照してください。
-
変更のないソースファイルの再インポートをスキップ。 ファイルインポートステップ(CSV、Excel、固定幅、JSON、Avro、Parquet、Alteryx yxdb、dbf、XML、Access)に、新しい ソースファイルが変更されていない場合は再インポートをスキップ オプションが追加されました。オンにすると、前回の正常な実行以降にソースファイルとステップの設定が変更されていない場合、ワークフローの実行でダウンロード、変換、テーブルの再構築のすべてがスキップされます。そのため、スケジュールされた再ロードが同じ作業を繰り返すことはなくなります。デフォルトでオン です。常に再インポートしたい場合は、ステップのオプションのチェックを外してください。変更は各ファイルのサイズと更新時刻、およびソースがハッシュを提供する場合はコンテンツハッシュで検出されます。手動の単発インポートは常に実行されます。Import CSVを参照してください。
-
ワークフローでの機械学習 — ML: モデルの学習ステップとML: スコアリングステップ。 任意のテーブルでモデルを学習し、そのモデルでデータをスコアリングして予測列を追加する処理を、すべてワークフロー内で行えます。線形回帰、ロジスティック回帰、決定木、ランダムフォレスト、勾配ブースティングを含む7つのアルゴリズムから選べます。学習済みモデルは他のテーブルと同様にワークフロー内を流れ、そのアルゴリズム、設定、特徴量、学習メトリックが一緒に記録されます。アルゴリズムや設定の入力ミスは、ステップの保存時に検出されます。ML: モデルの学習とML: スコアリングを参照してください。
-
PlaidCloudマネージドバケットのドキュメントアカウント。 完全マネージドのファイルストレージを、ワンステップでドキュメントに追加できます。クラウドプロジェクト、認証情報、リージョン、ストレージティアの設定やチューニングは不要です。BusinessプランとEnterpriseプランで利用できます。PlaidCloudマネージドバケットアカウントの追加を参照してください。
-
最小権限でOneDriveまたはSharePointサイトに接続。 OneDrive for BusinessまたはSharePointサイトを、Microsoft管理者が明示的に許可したサイトだけにアクセスできるドキュメントアカウントとして追加できます。これはMicrosoft 365テナント全体ではなく、MicrosoftのSites.Selectedモデルによるものです。アカウントのサービスとしてOneDriveを選び、アプリ登録のクライアントID、シークレット、テナントIDを入力し、許可されたサイトのURLを貼り付けて、そのドキュメントライブラリの1つを開始フォルダーとして選択します。許可していないサイト(給与、人事など)には一切アクセスできません。OneDrive / SharePointアカウントの追加を参照してください。
-
より高機能になったRESTリクエストステップ。 RESTリクエストは、ドライバーテーブルの行に対して呼び出しを展開できるようになりました。行ごとに1リクエストで、任意で行フィルターを指定でき、キー列を結果に引き継ぎます。同時実行数の制限、リクエストレートの上限、再実行を安全にするオプトインの冪等キー、エラー時に続行するオプション、行ごとの失敗の明確なレポートも備えています。新しい作成支援機能により、リクエストの作成と検証が簡単になりました。curlコマンドからのインポート、変数トークン(ドライバーテーブルの列を含む)の挿入とハイライト、展開の最初の行のテスト、実行前の解決済みリクエストとそのページングのプレビュー、未保存の下書きの復元、選択した接続のその場での編集、正常にテストしていないリクエストを保存する前の確認に対応しています。RESTリクエストステップを参照してください。
-
拡張されたヘルプとサポート。 チケットや返信にスクリーンショットやファイルを添付でき(画像はインライン表示)、並べ替えとフィルターが可能なサポートコンソールからチケットを処理できます(返信、内部メモの追加、担当者の設定、優先度の設定、PlaidCloudへのエスカレーション)。新規チケットの通知をSlack、Teams、メールのチャンネルに送ったり、チケットに返信があったときにチケットの所有者にメールを送ったり、長時間未回答のチケットを自動的にエスカレーションしたりできます。サポートを受ける、サポートコンソール、サポートの管理を参照してください。
-
AIへの質問のための分析パス。 最もよく分析するテーブルにわかりやすい名前を付け、1つをデフォルトに設定できます。これにより、毎回プロジェクトとテーブルを指定しなくても、あなたとAIアシスタントが「Operations Results」について、あるいは単に「前四半期で何が変わった?」と質問できます。Microsoft 365 Copilotと、MCPで接続されたすべてのエージェントで機能します。分析パスを参照してください。
-
より賢く、より正直なAI配賦コストトレース。 MCPで接続されたAIエージェントに配賦結果が変わった理由を尋ねると、回答に平易な言葉による確信度と注意事項が付くようになりました。原因が複数の要因の重なりである場合、現在の階層やドライバーの重みに依存する場合、あるいは変化の一部が単にデータロードの未完了による可能性がある場合に、それが明示されます。これらの信頼性を示すシグナルは、後続のエージェントが回答を要約した場合でも回答とともに引き継がれます。管理者は、基になるプールやドライバーのデータが最近再ロードされていない場合に、確信度を下げて回答にフラグを付けるオプションのチェックを有効にすることもできます。複数の配賦ブランチから構成される結果では、確信度は各ブランチが変化に占める割合で重み付けされるため、小さく不確かな1つのブランチが、それ以外は問題のない回答の評価を押し下げることはありません。また、ドライバー再重み付けのwhat-if質問(「このコストセンターの人員が2倍になったら?」)も可能になり、完全な根本原因分析をAIエージェント経由だけでなくREST APIからも実行できるようになりました。MCP接続のAIエージェントによる配賦のトレースを参照してください。
-
信頼でき、AIが検証もできる、書面のトレースサマリー。 MCPで接続されたAIエージェントに配賦結果が変わった理由を尋ねると、分析から直接作成された 平易な言葉のサマリーを返せるようになりました。サマリーには確信度が明記され、すべての注意事項が含まれ、実際のクエリに由来しない数値は引用されません。付属の 忠実性チェック により、エージェントは、言い換えた自身のバージョンが確信度とすべての注意事項を保持し、何も捏造していないことを確認できます。そのため、ナラティブは流暢なだけでなく、忠実であることが 証明可能 です。各サマリーは、自然な次の質問も提案します。単一のメンバーに絞り込む、ディメンションで変化を分解する、あるいは結果テーブルが複数のステップで作られている場合に特定の生成ステップを指定する、といったものです。正確な言い回しを知らなくても、掘り下げて調べられます。信頼できる回答を参照してください。
-
ビジュアルワークフローデザイナーでステップのデータをプレビュー。 新しいウィンドウを開かずに、ステップの出力をその場で確認できます。型付きの列、行数と列数、複数出力ステップ用のセレクターを備えた、最初の100行のプレビューを、キャンバスの下部にドッキングできます。別のステップをクリックするとプレビューの対象が切り替わり、実行が完了すると更新され、ワンクリックで完全なテーブルエクスプローラーを開けます。ステップデータのプレビューを参照してください。
-
Panelアプリを誤った変更からロック。 マイPanelアプリの各行にあるロックアイコンで、既存のワークフローロックやステップロックと同じようにアプリを保護できます。ロック中は、アプリの編集、削除、再ビルドが実行されず、サーバーアプリのブランチへのgit pushでも再ビルドされなくなります。一方、アプリを開く、ログ、使用状況メトリックは引き続き利用できます。これは誤操作に対する安全策であり、セキュリティ制御ではありません。Panelアプリを編集できるユーザーなら誰でもロックを解除できます。アプリのロックを参照してください。
-
ワークフローのステップに自動で番号を付与。 すべてのステップに番号が付くようになりました。ビジュアルキャンバス上のバッジ、ステップグリッドの先頭列、実行ログ、ワークフローのドキュメントレポート、AIアシスタントの一覧に表示される「ステップ 7」がすべて同じ番号です。インポートされた複雑なワークフローでも、名前でステップを説明する代わりに、チームメイトやAIエージェントに「ステップ 7」と示せます。番号はフローに従い(ステップは、入力元となるステップより必ず後の番号になります)、キャンバス上の位置は、左から右、次に上から下の順で同順位を解消します。ワークフローの編集に合わせて全員のキャンバスの番号がライブで振り直され、番号が変わったステップは短時間ハイライトされます。ステップを右クリックする(またはバッジをクリックする)と、「ステップ 7 — Clean Customer Names」のような、そのまま貼り付けられる参照をコピーできます。ステップ番号を参照してください。
-
2つの新しいワークフローステップ — Directory ListingとRow Count Assert。 ディレクトリ一覧ステップは、ドキュメントディレクトリ内のファイルのテーブルを書き出します(任意のファイルパターンとサブディレクトリのオプションがあります)。そのため、後続のステップは存在するファイルに応じて処理できます。行数アサーションステップは、2つのテーブルの行数が異なる場合にワークフローを失敗させる、データ品質のゲートです。ディレクトリ一覧と行数アサーションを参照してください。
-
ビジュアルワークフローデザイナーからワークフローのログへ移動。 キャンバスのツールバーの ログを表示 ボタンで、開いているワークフローで既にフィルターされたプロジェクトのログビューが開きます。これは、プロジェクトエリアから開く場合と同じ、完全な実行ログです。高度なワークフローを参照してください。
-
Table Updateは、ソースを変更する代わりにターゲットテーブルに書き込みます。 以前は Table In-Place Update と呼ばれていたステップは Table Update になり、新規ステップメニューに戻りました。ソースを読み取り、フィルターに一致する行を更新し、変更された行も変更されていない行も含めてすべての行を、選択したターゲットテーブルに書き込みます。比較用にソースはそのまま残ります。ターゲットの列は、ステップを最後に開いた後に上流で追加された列も含め、常にソースの列を反映します。更新がインプレースではなくなったため、テーブルのインプレース変更を許可しないウェアハウスを含め、すべてのウェアハウスで実行できます。ビューも有効なターゲットです。この変更より前に保存されたステップは、実行する前にターゲットテーブルの選択が必要です。また、更新後の行を期待してソースを読み取っていたステップは、新しいターゲットを指すように変更する必要があります。Table Updateを参照してください。
-
複数テーブル結合が動的なソースとターゲットのテーブルに対応。 テーブルピッカーで 動的 にチェックを入れ、リストから選ぶ代わりにテーブル名またはプロジェクトパスを指定します。どちらにも、ワークフローの実行時に解決される
{variable}トークンを含められるため、結合の結果を/03 Results/FACT_GL_{year}に書き込み、期間ごとに異なるテーブルを読み込めます。ターゲットが存在しない場合は作成されます。他のすべてのステップのテーブルは、すでにこの方法で動作していました。複数テーブル結合のステップだけは、リストから選んだテーブルが必須で、それ以外の方法では保存できませんでした。動的なソースの列はデザイン時に読み取れないため、サイドパネルで手動で入力します。複数テーブル結合ステップを参照してください。 -
複数テーブル結合の出力列に式または定数を指定可能。 出力列の値は、ソース列(それを所有するキャンバスのエイリアス付き)、定数、式 の3つのうち、ちょうど1つから取得されるようになりました。式の列を追加 は行を追加し、キャンバス上のすべてのテーブルを列ブラウザーに表示した完全な式エディターを開くため、複数の結合テーブルにまたがる値を作成できます。Post-Join Filter は単なるテキストボックスではなくこの同じエディターになり、
result.column_nameとして参照できる出力列が一覧表示されます。エディターのタブは3つになりました。内部専用の Advanced (server-set) タブはなくなりましたが、その設定は保存時に引き続き保持されます。複数テーブル結合ステップを参照してください。 -
ファイルのインポートが大きなファイルに対応し、ソースのデータ型を保持。 Excel、JSON、Parquet、Alteryx yxdb、dBASE、固定幅ファイルのインポートで、ファイル全体をメモリにロードしなくなりました。そのため、以前はメモリ不足エラーで失敗していた大きなファイルもインポートできます。実際の上限はメモリではなくディスク容量です。ソースのデータ型(小数、日付、タイムスタンプ)は、テキストを経由せずにターゲットテーブルへ引き継がれ、Parquetのタイムスタンプ列は時刻の精度を完全に保持します(以前は日付に切り詰められていました)。意図的に変更していない点があります。空の数値セルは引き続き0としてロードされ、ファイル名、パス、ワークシート名、行番号、最終更新日時の各列は従来どおり動作し、行番号はソースファイルごとにカウントされます。Import Excel、Import JSON、Import Parquetを参照してください。
-
JSONのインポートが改行区切りのファイルに対応し、標準的なJSONテキストを生成。 Import JSONステップは、JSON配列に加えて、改行区切りのJSON(NDJSON、1行に1オブジェクト)を受け付けるようになりました。ネストされたオブジェクトと配列は、Python形式の表記ではなく標準的なコンパクトなJSONテキストとしてテーブルに格納されるため、後続のステップはあらゆるJSONツールで解析できます。Import JSONを参照してください。
-
Git接続のリポジトリ、ブランチ、フォルダーを選択。 Git接続フォームで、リポジトリパス、ブランチ名、開始パスを入力する必要がなくなり、ライブのリストから選択します。サーバーと認証情報を入力し(PlaidCloud Git接続では入力するものはありません)、[更新]をクリックして接続が到達できるリポジトリを一覧表示し、1つ選んでそのブランチを読み込み、フォルダーを参照して任意の開始パスを設定します。そのため、名前の入力ミスで接続が気づかないうちに壊れることはありません。既存の接続を編集する場合は、保存済みのパスワードを再入力せずに参照できます。PlaidCloud Gitとすべての外部プロバイダー(GitHub、GitLab、Bitbucket、Forgejo、Gitea)に適用されます。PlaidCloud Git接続を参照してください。
-
AIコストトレースの精度が向上し、誤解を招きにくくなりました。 What-ifの見積もりは、上限値ではなく、展開先全体で合計が一致する、ターゲットごとの実際の数値になり、単一のターゲットに絞り込むこともできます。入力プールではなくドライバーテーブルやベーステーブルを指定した場合、エージェントは見積もりを辞退し、その理由を説明します。ドライバー再重み付けのwhat-ifは正確で、ドライバーが実際に分割する金額だけを動かし、パススルーのコストには手を加えません。エージェントは、誤解を招く形状(大きな増減が相殺されて小さな純変動になる合計や、ドライバーが支配するというよりほとんどがパススルーである変化)を認識して確信度を下げ、ドライバーが管理する金額が実際にどれだけ動いたかを示します。分割が信頼できない場合に単一の「支配的な要因」を過大に主張することもなくなりました。ディメンション階層の配賦についても、帰属先不明のままにせず説明します。データの鮮度チェックはドライバーテーブルとベーステーブルにも及び、複数の配賦ステップで生成された結果は、ステップを選択して(あるいは、フィルターで1つのステップだけが生成した行に絞り込まれた場合は自動的に)トレースできます。また、前年のデータがない前年比比較は、変化を「正常」とせず、その旨を伝えます。MCP接続のAIエージェントによる配賦のトレースを参照してください。
-
外部テーブル: ソースから単一テーブルの列を更新。 外部テーブルのインポートとエクスポートのステップで、テーブルごとの ソースを検査 ボタンが、選択したテーブルの現在の列を接続先データベースから直接読み取り、そのテーブルのマッピングだけをその場で更新するようになりました。ステップを作成した後にソーステーブルの列が変わった場合に便利で、接続全体に対してディスカバリーを再実行する必要はありません。外部データベーステーブルのインポートを参照してください。
-
ビジュアルワークフローデザイナーのプレゼンスに実際のアバターを表示。 複数の人が同じ高度なワークフローを開いているとき、ツールバーのプレゼンス行に、各ユーザーがGravatar(ない場合はイニシャル)で表示されます。同じユーザーが複数のブラウザータブで開いていても、表示は一度だけです。高度なワークフローを参照してください。
-
サーバーPanelアプリを開くときに実際の進行状況を表示。 起動中の画面は、起動全体を通して1つのメッセージを表示し、その後は汎用的なタイムアウトを表示していたため、まったく起動できないアプリと単に遅いだけのアプリの区別がつきませんでした。現在は、起動中、準備中、ロード中といった実際の段階を報告し、本当の失敗は根本的な理由とともに数秒以内に報告し、アプリがすでにウォーム状態の場合は直接開きます。起動はするがロード中に失敗するアプリ(たとえばパッケージの不足)は、空白のページを表示する代わりに、エラーとともに失敗として報告されます。Panelアプリの作成を参照してください。
-
Table Updateが保存時にNULLに設定を破棄しなくなりました。 列マッパーは、更新する列を ソース列 の見出しの下に表示し、ターゲット列 は空のままで、NULLに設定 のコントロールもありませんでした。さらにステップを保存すると、NULLに設定が指定されていたすべての列から設定が黙って削除され、ステップがそれらの値をクリアしなくなっていました。マッパーでは、定数、式、NULLに設定とともに 更新列 の見出しが表示され、4つすべてが保持されます。以前に列をクリアしていたステップがある場合は、NULLに設定にチェックが入ったままか確認してください。Table Updateを参照してください。
-
Table UpsertがStarRocksワークスペースでAPI経由でも動作。 これらのワークスペースで使われるマージは、ワークフローエンジンからは利用できましたが、REST APIからは利用できませんでした。APIはこの経路が使わないステートメントを要求していたため、そこではAPI経由でアップサートを実行できませんでした。Table Upsertを参照してください。
-
マクロ内のTable Upsertが、誤ったテーブルに書き込む代わりに停止するようになりました。 StarRocksワークスペースでは、マクロのコピーではなくプロジェクト自身のテーブルに黙ってマージしていました。現在は明確なエラーを報告し、これらのワークスペースでのマクロ内アップサートは、根本的な制限が解消されるまで利用できません。Table Upsertを参照してください。
-
複数テーブル結合ステップの保存時に修正が必要な箇所を報告。 解決すべき項目が残ったまま保存すると、何が問題かを伝える代わりに内部エラーで失敗していました。現在は、最初の問題があるタブに切り替わり、すべての問題が一覧表示され、各タブにその件数のバッジが付きます。キャンバスから選択… ピッカーが、操作できないステップフォームの背後に開くこともなくなりました。複数テーブル結合ステップを参照してください。
-
動的なExcelインポートが再び動作します。 保存済みの列マッピングではなくワークシートから列を検出するように設定されたExcelインポートは、実行のたびに失敗していました。現在は設定どおりにインポートされます。Import Excelを参照してください。
-
空のワークシートが、複数ワークシートのExcelインポートを失敗させなくなりました。 Excelインポートが複数のワークシートを対象としていて、そのうち1つが空の場合、ステップ全体を失敗させる代わりに、そのワークシートから0行をロードして処理を続行します。Import Excelを参照してください。
-
JSONインポートが、大きなドキュメントの後半に現れる列を欠落させなくなりました。 大きなJSONファイルの奥深くで最初の値が現れる列が、インポートされたテーブルから黙って欠落することがありました。現在はドキュメント内のすべての列が含まれます。Import JSONを参照してください。
-
AIアシスタントが、実行時に失敗する式を承認しなくなりました。
IF、AND、OR、NOTといった一部の式関数は、Pythonのキーワードと同じ名前であるため、末尾にアンダースコアを付けてfunc.if_(...)のように記述します。アシスタントはこれを逆に扱っており、実在しない関数で実行時に失敗するfunc._if(...)を承認し、正しいfunc.if_(...)を拒否していました。現在は、動作する形式を受け入れ、動作しない形式を拒否し、間違えたときには正しい綴りを示します。アシスタントが下書き時に参照する関数リファレンスも、これに合わせて修正されました。IFを参照してください。 -
Basic、APIキー、ベアラートークン認証のREST接続が、実際に認証されるようになりました。 これまではOAuth 2.0の認証情報だけが送信されていたため、他の3つのいずれかで構成された接続は、認証を確認するAPIに対して失敗していました。4つすべてが構成どおりに動作します。デフォルトヘッダー に認証情報を手動で入力して回避していた場合は、接続自身の認証が優先されるようになったため、その行は削除できます。汎用REST接続を参照してください。
-
PostmanコレクションやAPI仕様からのエンドポイント一覧表示が再び動作します。 RESTリクエストステップで、カタログをロード が、すべてのソース(ドキュメントから選んだものでも、アドレスから取得したものでも、Postmanコレクションでも、OpenAPI/Swagger仕様でも)でエラーを報告していました。現在はエンドポイントが一覧表示され、まだ選択していない場合は、先にファイルまたはアドレスを選ぶように案内します。RESTリクエストステップを参照してください。
-
REST接続のデフォルトヘッダーが実際に送信されるようになりました。 REST接続の デフォルトヘッダー に設定したヘッダーは、ステップのリクエストプレビューには表示されていましたが、実際のリクエストには含まれていませんでした。現在は、ページングされた読み取りの各ページや、行ごとの展開の各リクエストを含め、その接続を通じたすべてのリクエストで送信されます。個々のステップに設定したヘッダーは、接続上の同名のヘッダーより優先されます。デフォルトヘッダーを設定した接続がある場合は、それらが送信したい内容になっているか確認してください。汎用REST接続を参照してください。
-
サーバーPanelアプリのリポジトリへのプッシュでアプリが再ビルドされるようになりました。 PlaidCloud GitまたはGitHub接続からサーバーPanelアプリを公開する処理は常に機能していましたが、その後の接続のブランチへのプッシュは反映されませんでした。手動で再公開するまで、アプリは最初にビルドされたバージョンを提供し続けていました。現在は、GitからPanelアプリをデプロイするで説明されているとおり、プッシュによって自動的に再ビルドと再デプロイが行われます。ロックされたアプリは、ロックを解除するまで再ビルドをスキップします。既存のアプリや接続で必要な変更はありません。
-
ステップの実行条件の名前変更が再び動作します。 ステップの実行前に満たす必要のある条件を設定するとき、各条件の名前を変更できるようになりました。構成パネルの新しい 名前 フィールドを編集するか、リスト内の条件をダブルクリックします。条件を右クリックすると、名前の変更 と 削除 も選べます。ステップの実行条件を参照してください。
-
インポートで列を1つも読み取れない場合のエラーが分かりやすくなりました。 CSVまたはテキストのインポートを設定または自動作成するときに、PlaidCloudがソースファイルから列を1つも読み取れない場合(たとえば一部のMicrosoft Accessのテキストエクスポートや、区切り文字や引用符が一致しないファイル)、ステップが実行されてから分かりにくいメッセージで失敗するのではなく、インポートを保存または作成するときにすぐに通知されます。区切り文字、引用符、エスケープの設定を調整するか、ファイルを修正してから、もう一度お試しください。Import CSVを参照してください。
-
マネージドバケット名の衝突について説明が表示されるようになりました。 すでに使用されているバケット名でPlaidCloudマネージドバケットのドキュメントアカウントを作成すると、以前は汎用的な「Internal server error」で失敗していました。現在は バケット名 フィールドが衝突を直接示し、バケット名はグローバルに一意であることを説明して、より具体的な名前の付け方(たとえば、会社名を接頭辞として付ける)を案内します。PlaidCloudマネージドバケットアカウントの追加を参照してください。
-
OneDriveとSharePointのドキュメントアカウント — 参照とダウンロードの修正。 構成済みのOneDriveまたはSharePointのドキュメントアカウントを開くと、エラーで失敗せずに、フォルダーとファイルが確実に一覧表示されるようになりました。Microsoft管理者がサイトのリンク共有をオフにしている場合でも、ファイルをダウンロードできます。ダウンロードが共有リンクの作成に依存しなくなったため、ロックダウンされたサイトのファイルも、エラーにならずに開けます。OneDrive / SharePointアカウントの追加を参照してください。
-
インポートが読み取るテーブルを削除するときに警告されるようになりました。 インポート: 外部プロジェクトテーブル ステップが読み取るテーブルを削除すると、PlaidCloudはそれが使用中であると認識し、通常の削除を提示する代わりに、テーブルを強制的に削除しますか? チェックボックスにチェックを入れて強制削除を確認するよう求めます。そのため、他のプロジェクトが依存しているテーブルを誤って削除することはありません。これには、このプロジェクトのデータを共有する 別の プロジェクトのステップからの参照も含まれます。それらは、他のプロジェクトのステップの詳細なしで確認画面に表示されます(アクセス権がない場合があるためです)。Import Project Tableを参照してください。
-
結合ステップ — 出力列の修正。 内部結合、外部結合、アンチ結合、クロス結合の出力列タブには、2つのソースからマッピングした列だけが一覧表示され、マッピングしたソース列を削除すると古い行も削除されます。列マッパーのツールバーと複数行選択も復活しました。さらに、集計がデフォルトでオフのトグルになったため、結合によって出力が強制的にグループ化されることはなくなりました。オンにすると、新しい列にはデータ型に基づく集計がデフォルトで設定され、列ごとに上書きできます。複数テーブル結合の出力列は、結合グラフデザイナーでの名前の変更や削除に追従します。Table Inner Joinと複数テーブル結合ステップを参照してください。
-
RESTリクエストの信頼性の修正。 JSONリクエスト本文で変数が確実に置換されるようになりました。リクエストごとのタイムアウトと再試行の設定が反映されます(再試行は冪等なメソッドに限定されるため、POST/PUT/PATCHが再送されることはありません)。レート制限されたレスポンスはバックオフ付きで再試行され、キャプチャされた生のJSON内のリクエスト認証情報はマスクされます。テストリクエストは、成功した場合でもレスポンスのステータスコードを表示し、単一オブジェクトのレスポンスは1行としてインポートされます。センサーまたはWebフックでトリガーされるワークフローは、トリガーのメタデータと受信したペイロードを変数として読み取ることもできます。RESTリクエストステップを参照してください。
-
AIコストトレースの修正。 コストトレースは、スペースや記号を含むモデルの列名を扱えるようになり、フレンドリー名で指定されたテーブルを解決し、モデル実行ステップとプロジェクトコピーの結果で動作し、すべてのワークスペースタイプで機能します。異常検出は、異常に大きな変動にフラグを付け、四半期ラベル付きの期間を年をまたいでも実際の時間順に保ちます。また、2つのラベル付けのバグが修正されました。重み付けの基準が空から始まった場合の「ゼロからの」ジャンプと、前の値が負だった場合の符号が誤ったパーセント変化です。
-
Import/Export Project Tableが空のソースについて警告。 Import Project TableまたはExport Project Tableステップが、行のないソーステーブルからコピーする場合、ソースが空だったという警告付きで終了するようになりました。そのため、ステップが黙って成功したように見える代わりに、予期せず空になった結果に簡単に気づけます。ほとんどの場合、ステップの実行時にソースプロジェクトのデータがまだビルドされていなかったことを意味します。Import Project TableとExport to External Project Tableを参照してください。
-
テーブルバンドルが各列のディメンション、メモ、書式を引き継ぐようになりました。 テーブルをバンドルにエクスポートして別のプロジェクトにインポートすると、以前はインポートされたテーブルのすべての列で、ディメンションの関連付けが空のままで、列のメモと表示形式も失われていました。後続のステップは、読み取るテーブルから列の設定を引き継ぐため、インポートされたテーブルがこの欠落を、そこから構築されるすべてのものに伝播させる可能性がありました。これらの設定はバンドルとともに移動し、インポート時に復元されます。列が、移行先のプロジェクトに存在しないディメンションを指している場合、その関連付けだけが、壊れたリンクとして復元される代わりに破棄され、インポートログに記録されます。ディメンションを作成した後で、再度関連付けてください。この変更より前にエクスポートされたバンドルは、従来どおりにインポートされます。
-
作成して構成を開くで、DAGワークフローの正しいビューが開くようになりました。 新しい高度な(DAG)ワークフローで 作成して構成を開く ボタンを使うと、ビジュアルワークフローデザイナーのキャンバスではなく、従来のステップグリッドが開いていました。現在はキャンバスが開き、ワークフローをダブルクリックしたときと同じになります。高度なワークフローを参照してください。
-
Panelアプリの依存関係をアプリの隣に置けるようになりました。 Gitリポジトリからビルドされたサーバー側のPanelアプリは、リポジトリのルートにある
requirements.txtだけでなく、エントリポイントの隣に置かれたものもインストールするようになりました。そのため、共有リポジトリのサブフォルダーに保存されたアプリが独自のパッケージ(たとえばplotly、holoviews、hvplot)を宣言でき、ライブラリの不足で空白のまま表示されることはなくなります。Panelアプリの作成を参照してください。 -
大きなファイルや多数のドキュメントをフォルダー間で移動。 複数のファイル、または1つの大きなファイルを、あるドキュメントフォルダーから別のフォルダーへ一度に移動する処理が、確実に動作するようになりました。移動は、ファイル一覧の整合性を保つために1件ずつ実行され、大きな移動は途中で打ち切られず、完了に必要な時間が与えられます。
-
AIアシスタントが、アンダースコアで始まる名前の列を参照する式を拒否しなくなりました。 名前がアンダースコアで始まる列(たとえば
_MajorAccountFlag)を参照する式が受け入れられるようになりました。また、式が列に対してis、is not、notでテストしている場合(見た目とは異なり、列に対してはどの行にも一致しないか、エラーになります)、アシスタントは単に拒否するのではなく、有効な演算子(NULLテストにはis_(None)、そのほか!=、~)へ案内します。 -
AIアシスタントが有効な関数を拒否しなくなりました。 式ピッカーのリストになかった実在の関数(
rtrim、ltrim、to_char、substringなど多数)が未知として拒否されていました。また、関数名を大文字で書くと(func.SUM)、小文字の形式が受け入れられる場合でも拒否されていました。アシスタントは現在、ピッカーのリストに加えてワークスペース自身の関数リストと照合し、大文字と小文字を区別せずに確認します。 -
Panelアプリで文字が見えなくなる表示が解消されました。 プラットフォーム全体のテーマのデフォルトが、一致するページテンプレートを使用しないアプリを含むすべてのPanelアプリに適用されていました。そうしたアプリでは、白いページに白い文字が描画され、アプリは空白に見えるのに、ログには原因を示すものがありませんでした。アプリは、テーマ付きのテンプレートを選択しない限り、独自の外観を保つようになりました。既存のアプリには、次回の再ビルドまたは再公開時に反映されます。
-
起動中の画面がPanelアプリの外観を変えなくなりました。 サーバーPanelアプリの起動中、その背後の画面が独自の背景とライト/ダークの色を設定し、アプリはそれを上書きする手段なしに継承していました。そのため、アプリが誤ったキャンバスカラーで描画され、アプリ自身の設定ではなくオペレーティングシステムのライト/ダーク設定に従うことがありました。この画面は、アプリが起動すると完全に削除されます。また、開いたアドレスの内容が失われることもなくなりました。
?theme=darkをはじめとする、アプリが読み取るクエリパラメーターが、アプリに届きます。 -
アーカイブの展開でフォルダー構造が保持されます。
.zipや.tar.gzをドキュメントに展開すると、すべてが宛先フォルダーに平坦化されていました。data/master/accounts.csvを含むアーカイブからは単なるaccounts.csvが生成され、異なるフォルダーにある同名のファイルが衝突していました。ネストされたアーカイブは、フォルダーが保持されたまま展開されます。フラットなアーカイブと、単一ファイルの.gz/.bz2は変わりません。SFTPのドキュメントアカウントでは、宛先フォルダーがあらかじめ存在している必要があるため、ネストされたアーカイブは、そこで既に作成してあるパスに展開してください。 -
不正なスケジュールがイベントスケジューラーを壊さなくなりました。 使用できない繰り返し設定(30日の月の31日のように存在しない日付や、不正な形式のエントリ)を持つスケジュール済みイベントが1つあるだけで、ワークスペース全体のイベントスケジューラーの一覧とスケジュールカレンダーが内部サーバーエラーで失敗し、プロジェクトが開かなくなることもありました。読み取れないスケジュールは、次回実行が空白で表示されるだけになり、画面のそのほかの部分は通常どおりロードされます。イベントスケジューラーを参照してください。
-
ワークフローの失敗で、実際に何が問題だったかが分かるようになりました。 ワークフローのステップがバックグラウンドジョブ内で失敗したとき、実行ログと通知メールには、操作の汎用的なメッセージ(「Exception importing directly from remote sql」)だけが表示され、ソースシステムのパスワードの期限切れといった本当の原因は、どこにも表示されませんでした。現在は、根本的な失敗がログとメールに引き継がれます。多数のテーブルが同じ共通の原因で失敗した場合は、テーブルごとではなく一度だけ報告され、認証情報はメッセージから削除されます。
-
別のホストへのRESTリクエストが、接続の認証情報を送信しなくなりました。 RESTリクエストステップがパスではなく完全なアドレス(多くのAPIが返すページングリンクを含む)を使う場合、2つの問題がありました。アドレスが接続のホストに連結されてリクエストが完全に失敗すること、そしてリクエストの宛先に関係なく、接続の認証とデフォルトヘッダーが付加されることです。完全なアドレスはそのまま使用され、アドレスが接続自身のホストを指していない限り、認証情報とデフォルトヘッダーは送信されません。そのため、ページングは機能しつつ、サードパーティのアドレスに認証情報が渡ることはありません。RESTリクエストステップを参照してください。
-
Basic認証のREST接続を編集してもパスワードが失われなくなりました。 パスワードを再入力せずに、Basic認証を使うREST接続への変更を保存すると、保存済みのシークレットが破棄されていました。保存済みのパスワードは、4つすべての認証タイプで保持されるようになりました。リクエストプレビューの2つの不一致も修正されました。ステップで異なる大文字小文字で設定されたヘッダーが、実際のリクエストと同じ方法で統合され、空のヘッダー値は、文字列としての「None」ではなく空のまま送信されます。汎用REST接続を参照してください。
-
テーブルの結合で、各列のディメンションと書式が保持されます。 Union、Union All、配賦、複数テーブル結合が、複数のソースを1つの出力列にマージするとき、列のディメンション、メモ、書式の設定は、たまたま最後に並んだソースから解決されていました。ディメンションについて何も指定していないソースが、それを指定しているソースを打ち消すことがあり、似た列は復元されるのに、再構築のたびに列が関連付けられないままになっていました。現在は、ディメンションを指定しているソースが、指定のないソースより優先され、そのまま渡された列が名前を変更された列より優先され、ソース間の本当の不一致は、黙って解決されずにステップログに報告されます。集計された列の名前変更(
SUM(amount)からtotal_amountへ)でも、ソース列のディメンションが合計にコピーされなくなりました。合計は、そのメンバーを識別するものではありません。Table Union AllとTable Union Distinctを参照してください。 -
Table Meltが、作成したとおりの列マッピングを尊重します。 Meltのマッピングから意図的に除外した列が、裏でステップに追加し直されており、集計を行うステップではステップ全体が失敗していました。値の列を指定したマッピングは、記述したとおりに使用されるようになりました。Table Meltを参照してください。
-
別のプロジェクトからのテーブルのコピーが再び動作します。 プロジェクト間でテーブルをコピーするステップが、存在しなくなった操作を呼び出していたため、サーバー上で実行のたびに失敗していました。現在はImport Project Tableステップと同じ仕組みを使用し、ソースが空の場合は失敗せずに警告を報告します。Import Project Tableを参照してください。
-
行数アサーションがマクロ内で動作します。 Macro RunまたはMacro Concurrentステップ内にネストされた行数アサーションステップは、サーバー側のエラーで失敗していました。最上位の実行でのみ動作していたため、気づかれていませんでした。現在は、どの階層のネストでも正しく実行されます。行数アサーションを参照してください。
-
上流のコストプールがまだビルドされていない場合に、コストトレースが失敗しなくなりました。 配賦結果が変わった理由を尋ねたとき、配賦に入力するテーブルが生成されていなかった場合(通常はモデルのその部分が実行されていないことが原因)、以前は完全に失敗していました。現在はトレースが完了します。そのステージの測定された合計は引き続き報告し、上流の内訳は推測せずに帰属不可としてマークし、再トレースの前に再ビルドすべき入力を知らせます。合計が変化しなかったステージは、欠落したプールについて何かが測定されたことを示唆せずに、変化なしとして報告されます。
-
テーブルの詳細にライブの行数が表示されます。 テーブルの詳細を開くと、行数がウェアハウスから読み取られるため、SQLによってデータが書き込まれた後でも正確なままです。以前は、テーブルのシェイプが更新されるまで、古い数値が表示されることがありました。データストアが行数を推定しかできない場合は、正確なものとして表示される代わりに、概算としてマークされます。
-
レガシーなインポートおよびエクスポートステップを廃止 — SAS7BDATのインポート、HTMLのインポート、HTMLのエクスポートの各ステップが削除されました。これらの形式には、現在のインポートおよびエクスポートステップを使用してください。
-
X12 EDIインポートステップを廃止 — このステップタイプは削除されました。機能したことは一度もなく、X12 EDIのインポートは実行のたびに失敗していました。PlaidCloudでEDIデータが必要な場合は、CSVやJSONなどのサポートされている形式に変換して、それをインポートしてください。
-
アプリ内のパスワードのリセットオプションを廃止 — アカウント(アバター)メニューから パスワードのリセット 項目が削除されました。パスワードをリセットするには、サインインページの Forgot Password? リンクを使用してください。
セキュリティ
Section titled “セキュリティ”- セキュリティの割り当て変更がただちに反映されます。 セキュリティグループのスコープやメンバーの編集、グループの削除、メンバーのセキュリティグループの変更、メンバーの有効化と無効化は、いずれも遅れて適用されていました。ほとんどの権限では最大30秒、ワークスペースのGitサーバーへのアクセスでは、そのユーザーが次にサインインするまで反映されず、アクセスを取り消された人にとっては、永遠に反映されない可能性もありました。これらの変更はすべて、保存した瞬間にプラットフォーム全体に適用されるようになりました。設定の必要はありません。以前に付与または取り消したアクセスを確認してください。これからは正確に反映されます。セキュリティグループと割り当ての管理を参照してください。