KNIMEワークフローを移行する
PlaidCloudはKNIMEのドロップインの代替です。KNIMEノード設定の98.5%が完全に変換され、207種類のコアノードのうち205種類がFullです。各ノードは、そのノードの処理を行う標準のPlaidCloudワークフローステップになります。コンバーターは、KNIMEのワークフローアーカイブを実行可能な高度なワークフローに変換し、元のグラフを保持して、設定が必要な項目を示す変換レポートを返します。すべてのノードはKNIME変換マトリックスで確認できます。
変換で読み取るのは、指定したアーカイブだけです。KNIMEノードが読み取りや書き込みを行う先のシステムには接続しません。
変換は1回限りの操作です。同じアーカイブをもう一度変換すると新しいワークフローが作成され、PlaidCloudで加えた編集が後からのエクスポートとマージされることはありません。
PlaidCloudが作成するもの
Section titled “PlaidCloudが作成するもの”- KNIMEワークフローごとに1つの高度なワークフロー。
.knwfからは1つのワークフローが、.knarからはグループ内のワークフローごとに1つずつ作成されます。 - 各KNIMEノードは、対応するワークフローステップ、プロジェクト変数、またはキャンバスオブジェクトになり、上流と下流の関係は維持されます。メタノードとコンポーネントはワークフローに展開されるため、それらのノードは通常のステップとして実行されます。
- フロー変数と、ConfigurationノードおよびWidgetノードは、デフォルト値を保持するプロジェクト変数になります。変換時に値が確定しているスイッチとループは、削除され、実行されるステップに展開されます。
- KNIMEの式言語(Expression、String Manipulation、Math Formula、Column Expressions、Rule Engine)は、PlaidCloudの式に変換されます。
- アーカイブに含まれるデータファイルは、プロジェクトのデフォルトのドキュメントアカウントの
knime/フォルダーに、ワークフローごとに1つのフォルダーとしてアップロードされ、変換後のリーダーはそこからインポートします。 - ビュー、チャート、カラーマネージャーはデータに影響しません。これらは削除され、変換レポートに一覧表示されます。
- KNIME Analytics Platformからワークフローを
.knwfファイルとしてエクスポートします。複数のワークフローを一度に変換するには、ワークフローグループを.knarファイルとしてエクスポートします。リーダーが使用するファイルは、アーカイブに含まれるようにワークフローのdataフォルダーに置いてください。 - 読み取り可能なドキュメントアカウントにアーカイブをアップロードします。Analyzeアプリでは、インポートウィンドウの参照でお使いのコンピューターからアップロードできます。
- ワークフローを受け取るPlaidCloudプロジェクトを選択します。そのプロジェクトのアーキテクトまたはマネージャーであり、プロジェクトにデフォルトのドキュメントアカウントがある必要があります。
- ワークフローのリーダーとコネクターノードに使用させるPlaidCloudのテーブル、ファイル、接続を控えておきます。ソースをバインドするを参照してください。
ワークフローを変換する
Section titled “ワークフローを変換する”Analyzeアプリ、REST API、またはMCP接続のAIエージェントから変換します。REST APIとMCPツールは同じフィールドを受け取ります。ウィンドウでは、表示されているフィールドを使用します。
Analyzeアプリ
Section titled “Analyzeアプリ”- Analyzeを開き、Tools → Import KNIME Workflowを選択します。
- Import Source and Targetで、Target Projectと、ドキュメントアカウント内のKNIME Archive (.knwf or .knar) を選択します。お使いのコンピューターからアーカイブをアップロードするには、Browseを選択します。
- Object Prefixesで、必要に応じてWorkflow Prefix、Step Prefix、Table Prefixを設定します。テーブルプレフィックスのデフォルトはワークフローの名前です。
- Source Bindings (optional) で、必要に応じてリーダーをターゲットプロジェクト内の既存のテーブルにバインドします。Addを選択し、KNIME Reader(
12:3のようなノードID、ノード名、またはファイル名)とTable IDを入力します。接続、ドキュメント、他のプロジェクトのテーブルをバインドするには、REST APIまたはMCPツールを使用します。ソースをバインドするを参照してください。 - Importを選択します。
ウィンドウにはアーカイブの変換中は進行状況が表示され、その後に変換レポートが表示されます。レポートには、ステップ数(Steps、High confidence、Medium、Low、Not converted)、変換できなかったノードとその下流のステップ、部分的な変換、警告、アップロードするソースファイル、ステップのないノードが含まれます。確認が必要な項目がない場合はその旨が表示され、ウィンドウは自動的に閉じます。
| フィールド | 必須 | 内容 |
|---|---|---|
source_account_id |
はい | KNIMEアーカイブを保持するドキュメントアカウント。 |
source_file_path |
はい | そのアカウント内にある.knwfまたは.knarファイルのパス。 |
project_id |
はい | ワークフローを作成するプロジェクト。 |
workflow_prefix |
いいえ | ワークフロー名に付けるプレフィックス。 |
step_prefix |
いいえ | ステップ名に付けるプレフィックス。 |
table_prefix |
いいえ | テーブル名に付けるプレフィックス。デフォルトはワークフロー自身の名前です。既存のテーブル名と重複することになるプレフィックスは、何も作成される前に拒否されます。.knarの場合、各ワークフローのプレフィックスの後ろにそのワークフローの名前が付きます。 |
source_bindings |
いいえ | リーダーとコネクターノードを、すでにあるデータや接続にバインドします(最大500件)。ソースをバインドするを参照してください。 |
フィールドをJSON本文として次の宛先に送信します。
POST /rest/v1/analyze/knime/convert{ "source_account_id": "<document account id>", "source_file_path": "/knime/monthly-close.knwf", "project_id": "<project id>"}MCP接続のAIエージェントが、同じフィールドを指定してknime_convertツールを呼び出します。エージェントの接続方法はAIエージェント(MCP)を参照してください。このツールはプロジェクトを変更するため、承認する前に呼び出し内容を確認してください。
ソースをバインドする
Section titled “ソースをバインドする”source_bindingsを使用すると、KNIMEリーダーをアーカイブ内のコピーではなく、PlaidCloudにすでにあるデータに向けることができます。キーには、ノードID(12:3など)、ノード名、同梱ファイルのパス(data/sales.csvなど)、ファイル名のいずれかを指定でき、この順序で最初に一致したものが使用されます。値は次のいずれかです。
- ターゲットプロジェクト内のテーブルの
analyzetable_ID。そのテーブルがリーダーに置き換わります。 - 読み取り可能な別のプロジェクトのテーブルには、
{"project": "<project id>", "table": "<table id>"}。リーダーは、そのテーブルをコピーするImport Project Tableステップになります。ソースプロジェクトは、ターゲットプロジェクトに対して読み取りを共有している必要があります。共有していない場合、ステップは警告を出します。行アクセスで管理されているテーブルは拒否されます。 - 読み取り可能なドキュメントには、
{"account": "<document account id>", "path": "/finance/budget.xlsx"}。リーダーがそのドキュメントをインポートします。 - データベースまたはREST接続のコネクターノードには、
{"connection": "<connection id>"}。変換後のステップはその接続で実行されます。
Analyzeアプリのウィンドウでは、テーブルIDを使ってリーダーをターゲットプロジェクト内のテーブルにバインドします。接続、ドキュメント、他のプロジェクトのテーブルは、REST APIまたはMCPツールでバインドしてください。
"source_bindings": { "Sales": "analyzetable_1234", "data/budget.xlsx": { "account": "<document account id>", "path": "/finance/budget.xlsx" }}存在しないテーブルへのバインドや、どのリーダーにも一致しないキーは警告になります。適用されたバインドは、プロジェクト名とテーブル名とともに、変換レポートのbindingsに一覧表示されます。
バインドされていない入力
Section titled “バインドされていない入力”アーカイブにファイルがないリーダーは、デフォルトのドキュメントアカウントにあるワークフローのフォルダー内のinputs/<file name>から読み取ります。変換レポートのmissing_inputsにそのパスが警告とともに一覧表示されます。そのパスにファイルをアップロードして、ワークフローを実行してください。ファイルが置かれるまで、インポートは警告付きで完了して空のテーブルを作成し、ワークフローは続行されます。
認証情報と接続
Section titled “認証情報と接続”KNIMEの認証情報は移行されません。他のシステムにサインインする各ステップは、認証情報をPlaidCloudの接続または設定したプロジェクト変数から読み取ります。どちらを使用するかは、変換レポートのそのステップの警告に記載されます。
| KNIME | 設定する内容 |
|---|---|
| データベースコネクター | データベース接続。{"connection": "<id>"}でバインドするか、ステップで選択します。 |
| サインインを行うRESTおよびWebサービスノード | REST接続。{"connection": "<id>"}でバインドするか、ステップで選択します。 |
| Speech Recognizer (IBM Watson) | ベースURLが警告に示されたWatsonサービスURLで、ユーザーがapikey、基本認証のパスワードがお客様のAPIキーであるREST接続。ノードにバインドします。 |
| Email Connector(Email ReaderまたはEmail Mover併用) | 警告に示された名前を持つ、メールサーバーのパスワードを保持するプロジェクト変数。ホストとユーザーはEmail Connectorから取得されます。 |
| パスワード付きブックを使用するExcel ReaderまたはExcel Writer | 警告に示された名前を持つ、パスワードを保持するプロジェクト変数。 |
| LLMコネクターと認証ノード | AIステップのLLM接続。 |
プロジェクト変数の設定方法は、ワークフロー変数を管理するを参照してください。
変換レポートを読む
Section titled “変換レポートを読む”インポートが完了すると、Analyzeアプリのウィンドウに変換レポートが表示されます。RESTとMCPのレスポンスにも同じレポートが含まれます。ワークフローを実行する前に確認してください。
summaryは、作成されたステップ数と、信頼度が高、中、低でマッピングされたステップ数を示します。warningsは、各警告をノード、ステップ、および取るべき対応とともに一覧表示します。設定が必要なすべての認証情報と接続も含まれます。missing_inputsは、バインドされていない入力のファイルをアップロードするドキュメントのパスを一覧表示します。bindingsは、適用されたバインドを一覧表示します。table_prefixは、使用されたプレフィックスです。.knarの場合、workflowsに各ワークフローとそれぞれのプレフィックスが一覧表示されます。- レポートと並んで表示される
uploaded_filesは、デフォルトのドキュメントアカウントにアップロードされた同梱ファイルを一覧表示します。 dropped_toolsは、削除されたビューとチャートを一覧表示します。
プレースホルダー
Section titled “プレースホルダー”変換パスのないノードは、名前付きのプレースホルダーとしてキャンバスに残ります。プレースホルダーはデータをそのまま通過させ、KNIMEノードの名前とともに警告を出します。その下流のステップはすべてレポートでフラグが付けられるため、結果の欠落が見過ごされることはありません。結果が重要な場合は、標準のステップでその機能を再構築してください。
変換したワークフローを実行する
Section titled “変換したワークフローを実行する”- プロジェクトで新しいワークフローを開きます。
- 警告に示されたプロジェクト変数と接続を設定します。
- バインドされていない入力のファイルを、ウィンドウのSource files to uploadに示されたパス、または
missing_inputsのパスにアップロードします。 - ワークフローを実行し、各ステップの出力テーブルを確認します。
エッジケース
Section titled “エッジケース”KNIMEとの既知の違いは、以下のみです。
- Crosstab。 Table: Pivot ステップに変換されます。一部の設定の組み合わせでは、KNIMEと結果が異なります。
- Loop End (Column Append)。 テーブル: 内部結合 ステップに変換されます。一部の設定の組み合わせでは、KNIMEと結果が異なります。
- ランダム抽出。 Row Sampler、Table Partitioner、Equal Size Samplingは、Table KNIME Random Sample ステップでKNIME独自のランダム抽出を行うため、シードを指定したノードはKNIMEと同じ行を選択します。抽出できるテーブルは最大10,000,000行までで、それより大きいテーブルではステップが失敗します。