プロジェクトの管理
プロジェクトの検索は、階層の左下にあるフィルターボックスで行います。検索フィルターはプロジェクト名とラベルを照合し、結果を上の階層に表示します。
新規プロジェクトの作成
Section titled “新規プロジェクトの作成”新しいプロジェクトを作成するには、次の手順に従います。
- Analyze を開きます
- 上部のメニューバーから「プロジェクト」を選択します
- 「新規プロジェクト」ボタンをクリックします
- 「Access Control」セクションを含むフォームの情報を入力します
- 「Create」をクリックします
これで、アクセス権限の更新、オーナーの追加、ワークフローの作成を行えるようになります。
デフォルトのドキュメントアカウントの設定
Section titled “デフォルトのドキュメントアカウントの設定”プロジェクトのホームで、接続環境の横にあるデフォルトのドキュメントアカウントを選択します。解除するにはなしを選択します。
プロジェクト内では、すべてのファイルセレクターの先頭にProject Defaultが表示され、プロジェクトに現在設定されているアカウントを表します。プロジェクトを離れた場合、プロジェクトにデフォルトが設定されていない場合、そのアカウントが削除された場合、またはそのアカウントへのアクセス権がない場合は、一覧から外れます。
新しいファイルステップでは、プロジェクトにデフォルトがあればProject Defaultがあらかじめ選択されます。既存のステップが書き換えられることはありません。ドキュメントアカウントは、接続環境とは異なりステップごとに選ぶものであるため、各ステップは保存時のアカウントを、ご自身で変更するまで保持します。
Project Defaultに設定されたステップは、実行時にプロジェクトのデフォルトであるアカウントに解決されます。そのため、実行中にデフォルトを変更しても、まだ開始していないノードにのみ影響します。これは接続環境を変更した場合と同じです。ステップがProject Defaultで実行され、プロジェクトにデフォルトが設定されていない場合、別のアカウントにフォールバックせず、プロジェクトを示すエラーで実行が失敗します。
バージョン履歴
Section titled “バージョン履歴”プロジェクト内のすべてのオブジェクト(ステップ、UDF、ワークフロー、ディメンション、保存したレイアウト、ドキュメントやデータエディター、プロジェクト自体の設定)は、バージョン履歴のバックアップの対象です。バックアップは個々の保存のたびには取得されません。オブジェクトが保存されないまま 30 秒経過すると、その確定した状態のバックアップが 1 つ取得されます。短時間に何度も保存するなどの連続した編集でも、保存ごとにバージョンが作られるのではなく、最終結果を含む 1 つのバージョンだけが作成されます。バックアップの完了を待つために保存が遅くなることはありません。カウントダウンもバックアップ自体もバックグラウンドで実行されます。すぐにバージョンが必要な場合は、Back up nowを使うと、現在の状態を即座に取得して完了まで待機できます。この機能は UI、API、および *_versions MCP アクション backup から利用できます。バージョン履歴は Free を含むすべてのプランで利用できます。
過去のバージョンはポイントインタイムリカバリーに対応しており、オブジェクトを以前のバージョンに復元できます。ロックされたプロジェクト内では、ほかの変更と同様に復元も拒否されます。
バージョンはその場で復元されます。プロジェクト、ディメンション、ユーザー定義関数、ステップ、ワークフロー、またはデータエディターのバージョンを復元すると、同じ項目が置き換えられ、別の項目をターゲットとして指定すると拒否されます。たとえば「A project version is restored in place. Leave the target out, or set it to this project.」のようになります。復元は項目への変更であるため、編集と同じロールが必要です。行を制限するプロジェクトでは、プロジェクト、または制限対象の列が参照するディメンションを復元するには、プロジェクトのアーキテクトである必要があります。古いテーブルデータを別のテーブルとして取り戻すには、テーブルスナップショットを新しいテーブルに復元します。
この自動追跡に加えて、プロジェクトとその要素ではバージョン管理も利用できます。バージョンを簡単に作成できるだけでなく、あるバージョンの変更を別のバージョンにマージすることもできます。これにより、スナップショットを簡単に管理したり、開発用のバージョンを作成して、準備ができた時点でその変更を非開発バージョンにマージしたりできます。バージョン管理、比較、マージの実際の手順については、共同作業:バージョン、比較、共有を参照してください。
テーブルデータには独自の履歴があります。Lakehouse が書き込みのたびに取得するスナップショットで、テーブルスナップショットで説明しています。
AI アシスタントまたは MCP による復元と保持
Section titled “AI アシスタントまたは MCP による復元と保持”AI アシスタントまたは MCP では、dimension_versions が version_id を指定してディメンションのバージョンを復元、保持、解放します。restore_project はプロジェクト内のすべてのディメンションを最後のバックアップに戻します。また、*_versions の一覧(ステップ、UDF、ワークフロー、ディメンション、プロジェクト)には、各バージョンの version_id と保持されているかどうかが表示されます。いずれかの *_versions ツールまたは REST API による restore は、項目をその場で復元します。ターゲットを省略するか、項目自体を指定してください。project_upsert はロックされたプロジェクトのロックを解除でき、if_match に対応しているため、最後に読み取った後に行われた変更を上書きせず、失敗として扱います。
プロジェクトアクセスの管理
Section titled “プロジェクトアクセスの管理”アクセスの種類
Section titled “アクセスの種類”プロジェクトのセキュリティは、次の 3 種類のアクセスに簡素化されています。
- すべてのワークスペースメンバー
- 特定のメンバーのみ
- 特定のセキュリティグループのみ
プロジェクトのセキュリティは、次の手順で簡単に設定できます。
- Analyze を開きます
- 「プロジェクト」を選択します
- 制限したいプロジェクトの編集アイコンをクリックします
- 「Access Control」で目的の制限を選択します
- 「Update」をクリックします
プロジェクトへのアクセスを変更できるのは、プロジェクトのアーキテクトまたはテナント管理者のみです。変更できる対象は、アクセスの種類、プロジェクトに設定されたメンバーとセキュリティグループ、およびデータ共有です。それ以外のユーザーには、これらのパネルが読み取り専用で表示され、「Only project Architects can change access.」というメッセージが表示されます。
すべてのワークスペースメンバー
Section titled “すべてのワークスペースメンバー”「すべてのワークスペースメンバー」アクセスは最もシンプルなオプションです。ワークスペースのすべてのメンバーにアクセスを提供し、メンバーを個別に割り当てる必要がありません。
特定のメンバーのみ
Section titled “特定のメンバーのみ”「特定のメンバーのみ」のアクセス設定では、各メンバーをプロジェクトに割り当てる必要があります。メンバーをプロジェクトに割り当てるには、次の手順に従います。
- Analyze を開きます
- 上部のメニューバーから「プロジェクト」を選択します
- メンバーアイコンをクリックします
- 「Access」列で、メンバー名の横にあるチェックボックスをオンにしてアクセスを許可します
- 「Update」をクリックします
メンバー数の多いクラウドでは、この方法は想定以上の手間がかかることがあります。そのような場合にセキュリティグループが役立ちます。
特定のセキュリティグループのみ
Section titled “特定のセキュリティグループのみ”「特定のセキュリティグループのみ」オプションでは、特定のセキュリティグループにアカウントへのアクセス権限を割り当てられます。アクセス制限をセキュリティグループとの関連付けに基づかせることで、大規模なグループのアカウントアクセスの管理がはるかに簡単になります。これは、シングルサインオンによる自動グループ関連付けと組み合わせると特に便利です。シングルサインオンでメンバーのグループ割り当てを設定すると、これらのグループによってプロジェクトへのアクセスを暗黙的に有効化または無効化することもできます。
割り当てるグループを編集するには、次の手順に従います。
- Analyze を開きます
- 上部のメニューバーから「プロジェクト」を選択します
- セキュリティグループアイコンをクリックします
- 「Access」列で、セキュリティグループ名の横にあるチェックボックスをオンにしてアクセスを許可します
- 「Update」をクリックします
プロジェクト間でのデータ共有
Section titled “プロジェクト間でのデータ共有”データ共有を使うと、あるプロジェクトから別のプロジェクトのテーブルにアクセスできます。たとえば、Import Project Table ステップと Export Project Table ステップでプロジェクト間のデータを移動できます。共有は、データを共有する側のプロジェクトから、ほかの 1 つのプロジェクトに対して付与します。
- データを共有したいプロジェクトを開き、そのホームタブに移動します。
- データ共有の管理で、新規データ共有をクリックします。
- プロジェクトを選択で、このプロジェクトのデータを使用できるプロジェクトを選択します。
- 許可される操作で、読み取り、書き込み、またはその両方にチェックを入れ、データ共有を追加をクリックします。
データ共有を削除で共有を削除します。プロジェクトのデータ共有を追加または削除できるのは、プロジェクトのアーキテクトまたはテナント管理者のみです。
共有はプロジェクトに対して付与されるため、そのプロジェクトのメンバーとワークフローにのみ適用されます。
- 共有を通じた読み取りには、共有を付与されたプロジェクトでのロールが必要です。そこでロールを持たないユーザーは、共有から何も取得できません。
- 共有を通じた書き込み(共有元プロジェクトでのテーブル、フォルダー、ディメンションの作成)には、書き込み共有と、ご自身のプロジェクトでのマネージャーまたはアーキテクトのロールが必要です。これは、共有元で同じ変更を行えるロールです。それ以外のユーザーには「Writing to this project through a data share needs a write share from it to your project, and the Manager or Architect role in your project.」と表示されます。
ワークフローはそのプロジェクト自身のアイデンティティとして実行されるため、Import Project Table ステップと Export Project Table ステップは、誰が実行を開始しても共有を通じて動作します。
異なる表示ロールの設定
Section titled “異なる表示ロールの設定”プロジェクトでは、中間のステップを完了するために多くの変換やテーブルが必要になる一方、最終結果は少数のテーブルだけになることがよくあります。メンバーは、プロジェクトのすべての要素を表示する必要があるとは限らず、最終成果物だけで十分な場合もあります。PlaidCloud では、異なる表示ロールを設定して、各メンバーに表示される内容を簡単に整理、制御できます。
組み込みの表示ロールは、アーキテクト、マネージャー、エクスプローラーの 3 つです。
アーキテクトロールは最もシンプルで、プロジェクト、ワークフロー、テーブル、変数、データエディター、階層、ユーザー定義関数を完全に表示、制御できます。
マネージャーとエクスプローラーのロールには特定のアクセス権限はありませんが、カスタム定義できます。つまり、各グループにどの項目を表示するかを選択できます。
プロジェクト内のすべてを表示する必要がある場合は、全員をアーキテクトにできます。そうでない場合は、メンバーをマネージャーやエクスプローラーのプロジェクトメンバーに指定して、可視性を制御できます。
ロールを設定するには、次の手順に従います。
- Analyze を開きます
- 「プロジェクト」を選択します
- メンバーアイコンをクリックします
- ロールを変更したいメンバーを選択します
- 「Role」列で現在のロールをダブルクリックします
- 目的のロールを選択します
- 「Update」をクリックします
プロジェクト変数の管理
Section titled “プロジェクト変数の管理”プロジェクトやワークフローを実行する際、繰り返し行う作業のために変数を設定しておくと、煩雑さを減らして時間を節約できます。これらの変数は通常の代数の変数と同じように動作し、変数が何を表すか、その後にどの演算を行うかを設定できます。PlaidCloud では、これらの変数をプロジェクトレベルで設定してプロジェクト内のすべてのワークフローに影響させることも、ワークフローレベルで設定して特定のワークフローだけに影響させることもできます。
プロジェクトレベルの変数を設定するには、次の手順に従います。
- Analyze を開きます
- 「プロジェクト」を選択します
- 「Manage Project Variables」アイコンをクリックします
変数テーブルでは、変数を確認したり、現在の値を表示・編集したりできます。「New Project Variable」ボタンをクリックして、変数の追加や既存の変数の削除も行えます。
プロジェクトのコピー
Section titled “プロジェクトのコピー”プロジェクトをコピーは、プロジェクト全体、または選択した一部を、新しいプロジェクトまたは既存のプロジェクトにコピーします。
プロジェクトをコピーするには、次の手順に従います。
- Analyze を開きます
- 「プロジェクト」を選択します
- コピーするプロジェクトを選択します
- アクションボタンをクリックし、プロジェクトをコピーを選択します
- ターゲットを選択し、コピーする内容とデータ量を選んで、プロジェクトをコピーをクリックします
- コピー前の確認の概要を確認し、コピーを開始をクリックします
コピーする内容の選択
Section titled “コピーする内容の選択”選択ツリーには、プロジェクトが保持する内容が種類別(ワークフロー、ステップ、テーブル、ディメンション、データエディター、ユーザー定義関数)に表示されます。すべてをチェックしたままにするとプロジェクト全体をコピーし、必要な部分だけをチェックすることもできます。
それらの部分が何に依存しているかを調べる必要はありません。チェックしたものには、その依存関係も含まれます。ステップが読み書きするテーブル、ステップがロードまたは配賦の対象とするディメンション、呼び出すユーザー定義関数、呼び出すサブワークフローやマクロが対象です。ワークフローのセンサーはワークフローとともにコピーされます。
コピーされたセンサーは無効の状態で作成されます。 コピー先のプロジェクトで各センサーを有効にするまで、コピーでは何も起動しません。重複する項目を上書きするインポートでは、コピー先のワークフローにすでにセンサーがある場合、2 つ目のセンサーは追加されません。
新規プロジェクトへのコピー
Section titled “新規プロジェクトへのコピー”新しいプロジェクトの名前と ID を指定します。ID はそのスキーマ名になり、後から変更できません。
スケジュールは一時停止された状態で作成されます。 プロジェクト全体を新しいプロジェクトにコピーすると、各ワークフローのスケジュール済みイベントは一時停止された状態でコピーされるため、コピーが自動的に実行を開始することはありません。コピーが完了すると、元のプロジェクトで有効だったイベントを一覧にしたメッセージが表示されます。コピー側でイベントを実行するには、ツール > イベントスケジューラーで選択して選択を有効化をクリックします。詳しくは、イベントの一時停止を参照してください。
既存プロジェクトへのコピー
Section titled “既存プロジェクトへのコピー”プロジェクト一覧からターゲットを選択します。コピーは、そのプロジェクトを置き換えるのではなく、追加されます。
ターゲットを変更できる必要があります。 ロールを持たないプロジェクトへのコピーや、変更を防ぐためにロックされているプロジェクトへのコピーは拒否されます。この確認は何かを読み取ったり書き込んだりする前に行われるため、拒否されたコピーでターゲットが変更されることはありません。また、プロジェクトを自分自身にコピーすることはできません。
行を制限するプロジェクトのコピーには、プロジェクトのアーキテクトである必要があります。 コピーは行アクセスの制限がない新しいプロジェクトであり、コピー時にも「This copy is not row-restricted.」と通知されます。共有する前に、コピーで行アクセスを設定してください。行を制限する既存のプロジェクトにコピーする場合も同様に、そのプロジェクトのアーキテクトまたはテナント管理者のいずれかである必要があります。
ターゲットは独自の設定を保持します。 名前、ID、データ接続環境、ストレージのデフォルト、ドキュメントアカウント、アクセスの種類、アクセスリスト、行アクセスの付与は、すべてそのまま維持されます。選択した内容だけが取り込まれます。
Project Defaultに設定されたステップは、アカウントではなくその設定自体が引き継がれます。コピー後は、コピー元で設定されていたデフォルトではなく、ターゲットプロジェクトのデフォルトに解決されます。
受信した項目がターゲットにある項目と同一である場合は、処理を選択できます。
- 重複する項目を受信データで上書き — 受信したバージョンがターゲットのものを置き換えます。
- 重複する項目の新しいコピーを作成 — ターゲットは現在の内容を保持し、受信した項目は名前の末尾に
copyを付けて並べて追加されます。その名前も使用済みの場合は連番が付きます。
プロジェクト変数とワークフロー変数は、新規コピーの作成の例外です。変数は名前で識別されるため、何も参照していない名前に変更しない限り、2 つ目のコピーを追加することはできません。コピーにも含まれる変数がターゲットですでに定義されている場合は、ターゲット自身の値が保持され、コピーはそのまま残した変数を通知します。上書きは変数もほかの項目と同様に扱い、置き換えます。
この照合は名前ではなく同一性に基づきます。元々同じプロジェクトに由来する項目は同一の項目として認識されますが、たまたま同じ名前を持つだけの 2 つの項目は別の項目として扱われ、どちらも残ります。
コピーするデータ量の選択
Section titled “コピーするデータ量の選択”| モード | コピーされる内容 |
|---|---|
| 構造のみ | テーブル、ステップ、その他の選択内容。行は含まれません。 |
| 全データ | すべてのテーブルの行。同じ Lakehouse 内でも、Lakehouse 間でもコピーされます。 |
| サンプル | 各テーブルから、入力した行数までの行。新しいプロジェクトの場合のみです。数値は 1 から 1,000,000 までです。 |
サンプリングされたテーブルには、その行数までの行が含まれます。行数がそれより少ない場合は、すべての行が含まれます。
コピーの確認
Section titled “コピーの確認”コピーを開始する前に、コピー前の確認にコピーの概要が表示されます。コピー元のプロジェクト、コピー先、データモード、テーブルとビューの数、サイズ、推定時間、ソースとターゲットの Lakehouse、およびご注意の下の警告が含まれます。コピーを開始をクリックして開始するか、キャンセルをクリックして戻り、選択内容を変更します。
コピーを確認できるユーザー
Section titled “コピーを確認できるユーザー”データ付きで作成したコピーは、作成した本人だけが利用できます。準備ができたら、新しいプロジェクトから共有してください。行レベルセキュリティを持つプロジェクトのコピーも、同じ理由で非公開のままです。
既存のプロジェクトにデータをコピーするには、そのプロジェクトへの書き込みアクセスが必要です。
コピーが完了すると、コピー結果ウィンドウに各テーブルの結果が名前別に表示され、失敗したテーブルにはその理由が表示されます。失敗したテーブルを再試行をクリックすると、それらのテーブルだけを再度コピーします。再試行したテーブルの内容は置き換えられます。コピーが完了または失敗すると、メッセージとメールで通知されます。結果は、そのメッセージから、またはプロジェクトタブでコピーを選択してアクションメニューのインポートまたはコピーの結果を表示を選択することで、後から開き直せます。
結果は、誰かが破棄するまでコピーに残ります。コピーが完了したら、結果を破棄をクリックすると、プロジェクトを開けるすべてのユーザーに対して結果が削除されます。プロジェクトの内容は変わりませんが、失敗したテーブルはウィンドウから再試行できなくなります。破棄するにはプロジェクトの編集アクセスが必要で、プロジェクトがロックされていてはいけません。
プロジェクトのワークフローステップは、そのプロジェクト内のテーブルやその他のオブジェクトを参照しています。参照を更新は、それらの参照を元のプロジェクトではなくコピーを指すように書き換えます。ほとんどの場合これが望ましい動作であるため、デフォルトでオンになっています。オフにすると、コピーされたステップはコピー元のプロジェクトを指したままになります。
プロジェクトレポートの表示
Section titled “プロジェクトレポートの表示”プロジェクトやワークフローが動的な場合、詳細なドキュメントを維持することは困難です。この問題を解決するため、PlaidCloud はワークフロー、ワークフローステップ、ユーザー定義変換、変数、テーブルの詳細なドキュメントを提供するプロジェクトレベルのレポートを生成できます。このレポートはオンデマンドで生成され、プロジェクトの現在の状態を反映します。
レポートをダウンロードするには、次の手順に従います。
- Analyze を開きます
- 「プロジェクト」を選択します
- レポートアイコンをクリックします