Sage Intacct の財務を分析する — 接続から試算表まで
約 40 分 · Sage Intacct への接続、取り込み済みの試算表、部門別の損益計算書、ダッシュボード、スケジュールされた更新
これは、Sage Intacct を使うコントローラーや FP&A アナリストが最初の日に進める手順です。最後まで進めると、Intacct からディメンション別の勘定残高を直接取得し、財務諸表のように読める部門別の試算表と損益計算書に変換して、ダッシュボードに表示し、全体が自動的に更新されるように設定できます。既定レポートのエクスポートも、手作業での再入力も不要です。数値は Intacct から取得され、常に最新の状態に保たれます。
接続と取得は一度だけ行い、その後は最も重要な作業に取り組みます。残高の生データを、ビジネス担当者が月曜の朝に読む集計に整形する作業です。
- PlaidCloud ワークスペースと、作業用のプロジェクト(必要な場合はトライアルを開始してください)。
- 動作する Sage Intacct 接続。 最初に Sage Intacct への接続の手順を完了してください。Web サービスを有効にし、読み取るオブジェクトに対する権限を持つ Web サービスユーザーを用意する必要があります。また、接続には 4 つの認証情報フィールド(クライアントID、クライアントシークレット、Webサービスユーザーのユーザー名、会社ID)が必要です。ここから始める前に、接続が機能していることを確認してください。
- レポート対象の営業エンティティ(エンティティ ID)と、損益計算書の勘定科目(収益と費用)が含まれるおおよその勘定科目番号の範囲を把握しておいてください。以下の例では、エンティティに
201と301、損益計算書の範囲に4010~9999を使用しています。お使いの環境に合わせて置き換えてください。
ステップ 1: ワークフローを作成する
Section titled “ステップ 1: ワークフローを作成する”ワークフローは、データを取得して整形するパイプラインです。
- プロジェクトを開き、ワークフロータブに切り替えます。
- 新規ワークフローをクリックし、
Intacct Financialsなどの名前を付けて開きます。
ステップ 2: 試算表を取得する
Section titled “ステップ 2: 試算表を取得する”Sageのインポートステップは、日付範囲と勘定科目の範囲を指定して勘定残高を取得し、選択したディメンションをすべての行に付与します。これが試算表になります。
-
Sageのインポートステップを追加します。
-
構成で次の項目を設定します。
フィールド 値 接続 Sage Intacct 接続 会社 読み取り元の Intacct の会社 開始日 / 終了日 締める期間(例: 月の初日と最終日) Start account / End account 損益計算書の範囲(例: 4010~9999)エンティティ 営業エンティティ(例: 201、301)ディメンション レポートで使用するものを有効にします。一般的には場所、部門、従業員、クラスです -
ターゲットを、
intacct_trial_balanceという名前の新しいテーブルに設定します。 -
ステップを実行します。これで、勘定科目とディメンションの組み合わせごとに 1 行を持つテーブルができました。
startbalance、periodbalance、endbalanceの列と、有効にしたディメンションごとの ID と名前のペア(例:departmentid/departmentname、locationname)が含まれます。
ステップ 3: 残高を損益計算書に整形する
Section titled “ステップ 3: 残高を損益計算書に整形する”ここからが分析です。SQL を使わず、ポイント&クリック操作の変換 1 つで行います。損益計算書の範囲を、部門ごとに少数の財務諸表の行に集約し、収益がプラスで表示されるように符号を反転します。Table Extract ステップのテーブルデータの選択タブとデータフィルタータブで、すべて実行できます。
-
Table Extract ステップを追加します。ソースに
intacct_trial_balanceを、ターゲットに新しいテーブルintacct_pnlを設定します。 -
テーブルデータの選択タブで、集計をクリックして集計を有効にし、ターゲット列を 3 つ設定します。
departmentname— ソースからそのままマッピングします。タイプはテキスト、集計はグループ化です。pnl_line— 勘定科目番号をレポートの行に変換する式(下記)です。タイプはテキスト、集計はグループ化です。amount— 式func.to_float64(intacct_trial_balance.endbalance) * -1です。テキストの残高を数値に変換し、符号を反転します。タイプは通貨、集計は合計です。
amountターゲット列のタイプを通貨に設定することで、テキストの残高を合計できるようになります。pnl_lineでは、その式セルをダブルクリックして次のように入力します(列や条件グループのcase関数をポイント&クリックで選択できます)。case((func.to_float64(intacct_trial_balance.glaccountno) < 5000, '1 - Revenue'),(func.to_float64(intacct_trial_balance.glaccountno) < 6000, '2 - Cost of Goods Sold'),else_='3 - Operating Expenses',) -
ステップを実行します。
* -1 が唯一の会計上の操作です。Intacct では収益は貸方(マイナス)、費用は借方(プラス)として保持されるため、期末残高の符号を反転することで収益がプラス、コストがマイナスになり、各部門の行を合計すると純利益になります。case() の勘定科目番号の区切りは、お使いの勘定科目表に合わせて調整してください。式には PlaidCloud のポイント&クリックエディターを使用します。詳しくはデータマッパーの高度な使い方と式のリファレンスを参照してください。
ステップ 4: 財務担当者の目線で読む
Section titled “ステップ 4: 財務担当者の目線で読む”intacct_pnl テーブルを開きます。部門ごとに 3 つの数値があります。
| departmentname | pnl_line | amount |
|---|---|---|
| Operations | 1 - Revenue | 486,200.00 |
| Operations | 2 - Cost of Goods Sold | -190,540.00 |
| Operations | 3 - Operating Expenses | -212,880.00 |
この表から次の値をそのまま読み取れます。
- 売上総利益 = 収益 + 売上原価(売上原価はすでにマイナス)→
486,200 − 190,540 = 295,660。 - 純利益 = 3 つの行の合計 →
82,780。 - 売上総利益率(%) = 売上総利益 ÷ 収益 → 約 61%。
最初に行うべきことは照合です。同じ期間とエンティティについて Intacct 自身の損益計算書(財務レポート)を実行し、収益と純利益が一致することを確認します。一致しない場合は、ほとんどが範囲の違いです。含めていないエンティティ、損益計算書の一部が除外される勘定科目の範囲、期間の不一致などが原因として考えられます。照合が取れて初めて、このパイプラインを信頼できます。
ステップ 5: ダッシュボードに表示する
Section titled “ステップ 5: ダッシュボードに表示する”テーブルの数値でも十分ですが、CFO に送るのはグラフです。intacct_pnl を公開し、ダッシュボードを作成するの手順に沿って、次を追加します。
departmentnameごとの純利益(または収益)の棒グラフ- 収益、売上原価、営業費用の構成がひと目でわかるよう、
pnl_lineごとの棒グラフ
これで、エクスポート不要でワークフローが実行されるたびに更新される、Sage Intacct の財務ダッシュボードが完成しました。
ステップ 6: 更新をスケジュールする
Section titled “ステップ 6: 更新をスケジュールする”- ワークフロー全体を最初から最後まで一度実行し、すべてのステップが成功していることを確認します。
- ワークフローをスケジュールします。決算のサイクルに合わせて月次にするか、月中も数値を最新にしておきたい場合は週次にします。
取得はテーブル全体の置き換えになるため、実行のたびに、設定した日付と勘定科目の範囲の残高が再読み取りされます。履歴全体ではなく、必要な範囲(当期のみ、損益計算書の勘定科目のみなど)に絞ってください。
ステップ 7: 統計勘定から一人あたりの指標を追加する
Section titled “ステップ 7: 統計勘定から一人あたりの指標を追加する”Intacct は、財務の勘定科目表と並んで、人員数、床面積、数量などの金額以外の統計勘定も管理しています。統計モードに設定した 2 つ目のSageのインポートステップでこれらを取得し、損益計算書に結合して、部門別の従業員一人あたりの営業費用などの指標を算出します。標準ステップをさらに 3 つ追加するだけで、SQL は引き続き不要です。
-
2 つ目のSageのインポートステップを追加します。構成で次の項目を設定します。
フィールド 値 接続 Sage Intacct 接続 会社 読み取り元の Intacct の会社 開始日 / 終了日 ステップ 2 と同じ期間 統計 統計のみ Start account / End account 0000~9999。統計勘定が財務の勘定科目表の番号体系に収まっているとは限らないため、ステップ 2 の損益計算書の範囲ではなく、全範囲を取得しますエンティティ 営業エンティティ(例: 201、301)ディメンション 部門。一人あたりの指標をレポートする単位となるディメンションです -
ターゲットを、
intacct_statisticsという名前の新しいテーブルに設定します。 -
ステップを実行します。統計勘定と部門の組み合わせごとに 1 行が得られ、
endbalanceに統計値そのもの(例: 期末時点のその部門の人員数)が入ります。
次に、人員数を損益計算書に取り込んで割り算します。ただし、intacct_statistics から直接ではありません。このテーブルには統計勘定と部門の組み合わせごとに1 行(人員数、床面積、数量など、管理しているすべての統計)があるため、departmentname だけで結合すると、損益計算書のすべての行がその部門の統計勘定の数だけ増えてしまいます。その結果、amount_per_head はたまたまその行に結合された統計勘定で割られることになります。先に人員数に絞り込んで、結合が部門ごとに 1 行になるようにすると、比率が意味のあるものになります。
-
Table Extract ステップを追加します。ソースに
intacct_statisticsを、ターゲットに新しいテーブルintacct_headcountを設定します。テーブルデータの選択では、すべての列をそのまま伝播させます。ここでは集計は不要です。データフィルタータブで、ソースデータに対するデータのサブセットを選択フィルターを追加します:intacct_statistics.glaccountno == '9000'。9000は、お使いの人員数の統計勘定の番号に置き換えてください(取得結果が勘定科目名の列を返す場合は、その列で絞り込みます。glaccountnoは引き続きテキストなので、引用符で囲んだ文字列と比較します)。ステップを実行すると、intacct_headcountは部門ごとにちょうど 1 行になります。 -
Table Outer Join ステップを追加します。Table 1 に
intacct_pnlを、Table 2 にintacct_headcountを設定し、departmentnameで結合します。これで部門ごとに 1 対 1 の対応になります。結合タイプはデフォルトの左結合のままにします。損益計算書のすべての行が保持され、部門が一致する行には人員数が入ります。ターゲットは新しいテーブルintacct_pnl_with_headcountとし、両方のテーブルのすべての列を伝播させます。 -
ステップを実行し、
intacct_pnl_with_headcountを読み取って新しいテーブルintacct_pnl_per_headに出力する Table Extract ステップを追加します。テーブルデータの選択で既存の列を伝播させ、ターゲット列をもう 1 つ追加します。amount_per_headで、式はintacct_pnl_with_headcount.amount / func.to_float64(intacct_pnl_with_headcount.endbalance)、タイプは通貨です。 -
ステップを実行します。
3 - Operating Expenses の行の amount_per_head を見ると、部門別の従業員一人あたりの営業費用を読み取れます。ステップ 4 と同じ読み方で、列が 1 つ増えただけです。損益計算書と並べてダッシュボードに追加するか、ステップ 6 のスケジュールに含めて、他のものと一緒に更新されるようにします。
作成した内容
Section titled “作成した内容”空のワークフローから始めて、Sage Intacct の勘定残高のライブデータを取得し、標準の変換ステップ 1 つで部門別の損益計算書に整形しました。さらに統計勘定を結合して一人あたりの指標を算出しました。パイプライン全体で SQL は使っていません。ダッシュボードに表示し、更新をスケジュールしました。財務チームが行う中核的なレポートの流れが、これで自動化されました。
次のステップ
Section titled “次のステップ”- Sage Intacct への接続 — 接続の設定と、その他の Sage のインポートステップ(買掛金請求書、買掛金明細、アドホックなオブジェクトクエリ)です。
- Sage Intacct クエリのインポート — 任意の Intacct オブジェクト(総勘定元帳の勘定科目、顧客、プロジェクト)を取得して、財務諸表を補強します。
- Table Extract ステップとデータマッパーの高度な使い方 — より深い分析のためのグループ化、フィルター、計算列です。
- ディメンション階層を設計する — 勘定科目表を、自分で管理できるレポート用のグループに集約します。