管理项目
使用层次结构左下方的筛选框即可搜索项目。搜索筛选器会匹配项目名称和标签,并将结果显示在上方的层次结构中。
创建新项目的步骤如下:
- 打开 Analyze
- 在顶部菜单栏中选择“项目”
- 点击“新建项目”按钮
- 填写表单信息,包括“访问控制”部分
- 点击“创建”
此时项目已可用于更新访问权限、添加所有者和创建工作流。
设置默认文档账户
Section titled “设置默认文档账户”在项目主页的 Connection Environment 旁边,为项目选择一个默认文档账户,或选择无以清除。
在项目内部,每个文件选择器都会将 Project Default 列在最前面,代表项目当前设置的账户。离开项目、项目未设置默认账户、该账户已被删除或您无权访问该账户时,它都会从列表中消失。
当项目设置了默认账户时,新建文件步骤会预先选中 Project Default。现有步骤不会被改写,每个步骤会一直沿用保存时所用的账户,直到您自行更改,因为文档账户是逐个步骤做出的选择,这一点与连接环境不同。
停留在 Project Default 的步骤,会在运行时解析为项目当时的默认账户,因此在运行中途更改默认账户只会影响尚未开始的节点,这与更改连接环境相同。如果某个步骤使用 Project Default 运行,而项目没有设置默认账户,则运行会失败并指明该项目,而不会回退到其他账户。
项目中的每个对象,包括步骤、UDF、工作流、维度、已保存的布局、文档或数据编辑器,以及项目自身的设置,都受版本历史备份的保护。备份并不会在每次保存时都进行;相反,一个对象在 30 秒内没有再次保存后,就会对其稳定状态进行一次备份。一连串的编辑(短时间内多次保存)只会产生一个包含最终结果的版本,而不是每次保存一个版本。保存永远不会因等待备份而变慢:倒计时和备份本身都在后台运行。如果需要立即得到一个版本,请使用 Back up now 立即捕获当前状态并等待其完成,该功能可在界面、API 以及 *_versions MCP 操作 backup 中使用。所有套餐(包括免费版)均提供版本历史。
过去的版本支持时间点恢复:将对象还原到较早的版本。在已锁定的项目中,还原会被拒绝,与该项目中的其他任何更改一样。
版本会就地还原。还原项目、维度、用户定义函数、步骤、工作流或数据编辑器的某个版本时,会替换该项本身,而指定其他项作为目标会被拒绝,例如“A project version is restored in place. Leave the target out, or set it to this project.”。还原属于对该项的更改,因此所需的角色与编辑它相同;对于限制行访问的项目,还原项目或受限列所读取的维度需要项目架构师。若要将旧的表数据作为单独的表找回,请将表快照还原为新表。
除了这种自动跟踪之外,项目及其元素还支持版本管理。创建版本不仅简单,还可以将更改从一个版本合并到另一个版本。这提供了一种简便的方式来记录快照,或创建开发用版本,并在需要时将这些更改合并到非开发版本中。有关版本管理、比较和合并的实际操作,请参阅协作:版本、比较与共享。
表数据有自己的历史,即 Lakehouse 在每次写入时生成的快照,详见表快照。
通过 AI 助手或 MCP 还原和保留
Section titled “通过 AI 助手或 MCP 还原和保留”通过 AI 助手或 MCP,dimension_versions 可按 version_id 还原、保留和释放维度版本,restore_project 可将项目中的每个维度回滚到其最近一次备份,而每个 *_versions 列表(步骤、UDF、工作流、维度、项目)都会显示每个版本的 version_id 以及它是否被保留。通过任何 *_versions 工具或 REST API 执行的 restore 都会就地还原该项:省略目标,或将其设置为该项本身。project_upsert 可以解锁已锁定的项目,并支持 if_match,这样当自您上次读取项目以来有人做出更改时,它会失败而不是覆盖该更改。
管理项目访问
Section titled “管理项目访问”项目安全性已简化为三种访问类型:
- 所有工作区成员
- 仅限指定成员
- 仅限指定安全组
设置项目安全性很简单:
- 打开 Analyze
- 选择“项目”
- 点击要限制的项目的编辑图标
- 在“访问控制”下选择所需的限制
- 点击“更新”
只有项目架构师或租户管理员才能更改谁可以访问项目,包括其访问类型、其中的成员和安全组,以及其数据共享。其他人看到的这些面板是只读的,并带有提示“Only project Architects can change access.”。
所有工作区成员
Section titled “所有工作区成员”“所有工作区成员”访问是最简单的选项,因为它向工作区的所有成员提供访问权限,无需额外为项目分配成员。
仅限指定成员
Section titled “仅限指定成员”“仅限指定成员”访问设置要求将每个成员分配到项目。将成员分配到项目的步骤如下:
- 打开 Analyze
- 在顶部菜单栏中选择“项目”
- 点击成员图标
- 在“访问”列中,勾选成员姓名旁的复选框以授予其访问权限
- 点击“更新”
对于成员数量众多的云环境,这种方式往往比预期更费力,此时安全组就派上了用场。
仅限指定安全组
Section titled “仅限指定安全组”“仅限指定安全组”选项可以为特定的安全组分配访问账户的权限。由于访问限制依赖于与一个或多个安全组的关联,因此对较大群体的账户访问管理要简单得多。与单点登录的自动分组关联结合使用时尤其有用。通过单点登录设置成员的分组归属,这些分组还可以隐式地启用和禁用对项目的访问。
编辑已分配的安全组:
- 打开 Analyze
- 在顶部菜单栏中选择“项目”
- 点击安全组图标
- 在“访问”列中,勾选安全组名称旁的复选框以授予其访问权限
- 点击“更新”
在项目之间共享数据
Section titled “在项目之间共享数据”数据共享使一个项目可以访问另一个项目的表,例如,让 Import Project Table 步骤和 Export Project Table 步骤可以在两者之间移动数据。共享由数据被共享的项目授予另一个项目:
- 打开要共享其数据的项目,进入其主页选项卡。
- 在数据共享管理下,点击新建数据共享。
- 在选择项目下,选择可以使用此项目数据的项目。
- 在允许的操作下,勾选读取、写入或两者,然后点击添加数据共享。
删除数据共享会移除一个共享。只有项目架构师或租户管理员才能添加或删除项目的数据共享。
共享是授予某个项目的,因此它只代表该项目的成员及其工作流:
- 通过共享读取,需要在被授予共享的项目中拥有角色。在该项目中没有角色的人无法通过共享获得任何内容。
- 通过共享写入(在共享项目中创建表、文件夹或维度),需要写入共享,以及您自己项目中的管理者或架构师角色,即能够在该项目中做出同样更改的角色。其他人会收到提示“Writing to this project through a data share needs a write share from it to your project, and the Manager or Architect role in your project.”
工作流以其所属项目自身的身份运行,因此无论由谁启动运行,Import Project Table 和 Export Project Table 步骤都能通过共享工作。
设置不同的查看角色
Section titled “设置不同的查看角色”很多时候,一个项目可能需要若干转换和表来完成中间步骤,而最终结果可能只包含少数几个表。成员并不总是需要查看项目的所有元素,有时只需要最终成果。PlaidCloud 允许您设置不同的查看角色,以便轻松精简并控制每位成员的可见内容。
内置了三种查看角色:架构师、管理者和探索者
架构师角色最为简单,因为它允许完整查看和控制项目、工作流、表、变量、数据编辑器、层次结构和用户定义函数。
管理者和探索者角色没有特定的访问权限,但可以自定义。换句话说,您可以选择每个分组可见的项目。
如果您认为需要查看项目内的所有内容,可以让所有人都成为架构师;否则,可以将成员指定为管理者和/或探索者项目成员,并以此控制可见性。
设置不同角色的步骤如下:
- 打开 Analyze
- 选择“项目”
- 点击成员图标
- 选择要更改其角色的成员
- 在“角色”列中双击其当前角色
- 选择所需的角色
- 点击“更新”
管理项目变量
Section titled “管理项目变量”运行项目或工作流时,为重复性任务设置变量可能很有用,这样可以减少杂乱并节省时间。这些变量的作用就像普通的代数变量一样,允许您设置变量所代表的内容以及其后应执行的运算。PlaidCloud 允许您在项目级别设置这些变量(会影响该项目内的所有工作流),也可以在工作流级别设置(只影响该特定工作流)。
设置项目级变量的步骤如下:
- 打开 Analyze
- 选择“项目”
- 点击管理项目变量图标
在变量表中,您可以查看变量并查看/编辑其当前值。您还可以通过点击“新建项目变量”按钮来添加新变量或删除现有变量。
复制项目可将项目(全部或仅您选择的部分)复制到全新的项目或已有的项目中。
复制项目的步骤如下:
- 打开 Analyze
- 选择“项目”
- 选择要复制的项目
- 点击操作按钮并选择复制项目
- 选择目标,选择要带过去的内容以及数据量,然后点击复制项目
- 查看复制前审核摘要,然后点击开始复制
选择要复制的内容
Section titled “选择要复制的内容”选择树按类型列出项目包含的内容,包括工作流、步骤、表、维度、数据编辑器和用户定义函数。保持全部勾选即可复制整个项目,也可以只勾选所需的部分。
无需自行梳理这些部分所依赖的内容。您勾选的任何内容都会连同其依赖项一起复制:步骤读取和写入的表、它加载或据以分摊的维度、它调用的用户定义函数,以及它所调用的任何子工作流或宏。工作流的传感器会随工作流一起复制。
复制的传感器会处于禁用状态。 在您于目标项目中逐个启用传感器之前,副本上不会触发任何内容。如果目标工作流中已经有某个传感器,则覆盖重复项的导入不会再添加第二个传感器。
复制到新项目
Section titled “复制到新项目”为新项目指定名称和 ID。ID 将成为其架构名称,之后无法更改。
计划会处于暂停状态。 将整个项目复制到新项目时,每个工作流的计划事件都会以暂停状态带过去,因此副本不会自行开始运行这些事件。复制完成后,会有一条消息列出原项目中处于活动状态的事件。若要在副本上运行某个事件,请在工具 > 事件调度器中选择它,然后点击启用所选项,详见暂停事件。
复制到已有项目
Section titled “复制到已有项目”从项目列表中选择目标。复制是向该项目添加内容,而不是替换它。
您需要有权更改目标。 复制到您没有任何角色的项目会被拒绝,复制到已锁定以防更改的项目同样如此,这些检查在读取或写入任何内容之前进行,因此被拒绝的复制不会影响目标。项目也不能复制到其自身。
复制限制行访问的项目需要项目架构师。 副本是没有行访问限制的新项目,复制时也会提示:“This copy is not row-restricted.”请在共享之前为副本设置行访问。同样,复制到限制行访问的已有项目,需要该项目的架构师之一或租户管理员。
目标保留其自身的设置。 其名称、ID、数据连接环境、存储默认值、文档账户、访问类型、访问列表和行访问授权都保持不变。只会带入您选择的内容。
设置为 Project Default 的步骤带过去的是该设置,而不是某个账户,复制后它会解析为目标项目所拥有的默认账户,而不是它在源项目中所用的账户。
当传入的项与目标中已有的项是同一项时,由您选择如何处理:
- 用传入数据覆盖重复项:传入的版本会替换目标中的版本。
- 创建重复项的新副本:目标保留现有内容,传入的项会添加到旁边,名称后附加
copy,如果该名称也已被占用,则再加一个计数。
项目变量和工作流变量是“新建副本”的例外:变量由其名称标识,因此无法在不将其重命名为没有任何内容引用的名称的情况下添加第二个副本。如果目标已定义了副本也携带的变量,则保留目标自身的值,并且副本会告诉您哪些变量未被处理。“覆盖”则像对待其他所有内容一样替换变量。
这种匹配依据的是标识而非名称:最初来自同一项目的项会被识别为同一项,而仅仅碰巧同名的两个项会被视为不同的项,之后两者都会存在。
选择复制多少数据
Section titled “选择复制多少数据”| 模式 | 复制的内容 |
|---|---|
| 仅结构 | 表、步骤以及所选的其余内容,不含行。 |
| 完整数据 | 每个表的所有行,同一 Lakehouse 内以及跨 Lakehouse 均适用。 |
| 样本 | 从每个表中复制不超过您输入的行数,仅适用于新项目。该数字可以是 1 到 1,000,000。 |
抽样的表最多包含该数量的行,行数不足时则包含全部行。
在复制任何内容之前,复制前审核会汇总此次复制:来源项目、目标位置、数据模式、表和视图的数量、大小、预计时间、源 Lakehouse 和目标 Lakehouse,以及请注意下的所有警告。点击开始复制开始,或点击取消返回并更改选择。
谁能看到副本
Section titled “谁能看到副本”带数据的副本仅对创建者本人私有。准备好后,请在新项目中共享它。具有行级安全的项目的副本出于同样的原因保持私有。
将数据复制到已有项目需要对该项目拥有写入权限。
复制完成后,复制结果窗口会按名称列出每个表的结果,并给出任何失败的表的原因。点击重试失败的表可仅再次复制这些表;重试的表的内容会被替换。复制完成或失败时,您会通过消息和电子邮件收到通知,您可以从消息中重新打开结果,也可以稍后在项目选项卡上选择该副本,然后从操作菜单中选择查看导入或复制结果。
结果会一直保留在副本上,直到有人将其忽略。复制完成后,点击忽略结果可为所有能打开该项目的人移除结果。项目中的任何内容都不会改变,但无法再从该窗口重试其失败的表。忽略结果需要对项目拥有编辑权限,并且项目不能处于锁定状态。
项目的工作流步骤引用该项目内的表和其他对象。更新引用会重写这些引用,使其指向副本而不是原项目,这几乎总是您想要的,也是它默认开启的原因。关闭它会使复制的步骤继续指向其来源项目。
查看项目报表
Section titled “查看项目报表”当项目或工作流处于动态变化时,维护详尽的文档会成为一项挑战。为帮助解决这一问题,PlaidCloud 提供了生成项目级报表的功能,可对工作流、工作流步骤、用户定义转换、变量和表给出详细文档。该报表按需生成,反映项目的当前状态。
下载报表的步骤如下:
- 打开 Analyze
- 选择“项目”
- 点击报表图标